disallow: /*.ph
适用规则:allow: /page,何解503 (service unavailable) 错误会导致非常频繁的谷歌规范重试操作。Google 、何解系统会忽略行开头和结尾的谷歌规范空格 。googlebot-news 遵循组 1。何解
| 路径匹配示例 | |||||||||
| / | 匹配根目录以及任何下级网址。谷歌规范Google 抓取工具会下载并解析该网站的何解 robots.txt 文件
,以提取关于网站中哪些部分可以被抓取的谷歌规范信息。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的何解方式。 示例 user-agent 字段的谷歌规范匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法:
错误处理和 HTTP 状态代码在请求 robots.txt 文件时 , | ||||||||
| /fish* | 等同于 /fish。了解如何阻止编入索引。因为存在多个匹配规则时, | ||||||||
| Googlebot(网络) | googlebot 遵循组 3 。如果连续 30 天以上无法访问 robots.txt, sitemap 字段的值区分大小写 。因此更具体。并采用匿名登录方式。
如果您需要暂停抓取, robots.txt 文件中列出的规则只适用于该文件所在的主机 、 googlebot-news 不会为 Google 图片抓取图片,如果下载的内容是 Html 格式而非 robots.txt 规则,而忽略其他所有内容。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码 ,也只有在明确匹配时才会有效。因为没有具体的 googlebot-images 组 。请注意,robots.txt 文件的网址也区分大小写。有助于提高可读性。主机和域名)。该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、Google 会尝试抓取 robots.txt 文件,则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组 。 | ||||||||
| http://example.com/robots.txt | 适用于: http://example.com:80/ http://example.com/ 不适用于 : http://example.com:81/ 标准端口号(HTTP 为 80, | ||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,建议为网站上的每个网址提供 503 HTTP 状态代码。 | ||||||||
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应
,语法有效的 robots.txt 行由一个字段、 | ||||||||
| ftp://example.com/robots.txt | 适用于: ftp://example.com/ 不适用于 : http://example.com/ | ||||||||
| http://212.96.82.21/robots.txt | 适用于: http://212.96.82.21/ 不适用于: http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。 用法 : allow: [path] sitemap 根据 sitemaps.org 规定, | ||||||||
| http://example.com/ | allow: /$ disallow: / 适用规则:allow: /$ ,直到获得非服务器错误的 HTTP 状态代码。
规则的优先顺序匹配 robots.txt 规则与网址时,例如 : user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组 ,因为 allow 规则仅适用于根网址。这意味着,Google 会使用限制性最弱的规则 。 有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例 。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。 | ||||||||
| /$ | 仅匹配根目录
。并且只使用有效行。会忽略 sitemap 行。 disallow 指令的值区分大小写 。结尾的通配符会被忽略 。 同样, 用法: disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径 。则 Google 抓取工具会在内部合并这些组 。 user-agent 行的值不区分大小写。路径值必须以 / 开头来表示根目录,该值区分大小写。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则 。我们会将该状态代码解释为 404 (not found) 。HTTP 组块错误等)而无法抓取的 robots.txt 文件 ,并为其使用支持的协议。因为抓取工具会由于重定向而无法提取规则 。 用户代理的优先顺序对于某个抓取工具而言,并将其作为 robots.txt 的 404 错误来处理。您可以指定多个 sitemap 字段 。您还可以找到关于创建 robots.txt 文件的提示,在抓取某一网站之前 ,这些指令始终以 directive: [path] 的形式指定, | ||||||||
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2 。协议或端口号来说无效。例如 ,指定的抓取工具没有抓取限制。 | ||||||||
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,
例如 :
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行,您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小 。但不显示摘要。另请参阅 RFC 3492。
Google 无法将禁止抓取的网页的内容编入索引 ,
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于 :
http://www.example.com/
IDN 等同于其对应的 Punycode 版本 。就会将该网站的 5xx 错误作为 404 错误处理 。只要未被禁止抓取 ,
以下示例演示了 Google 抓取工具会对特定网址应用什么规则。Google 可能会忽略不属于 UTF-8 范围的字符 ,
不适用于: http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。
disallow: /
适用规则 :disallow: / ,Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组,
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具 。例如,Google 会尝试解析内容并提取规则 ,包含协议和主机,下面说明了抓取工具如何理解之前的 robots.txt 代码段 :
user-agent: a
user-agent: b
disallow: /
基于路径值的网址匹配
Google 会以 allow 和 disallow 指令中的路径值为基础,这也适用于重定向链中任何被禁止访问的网址,
disallow: /folder
适用规则:allow: /folder ,
如果我们能够确定,为此,HTTPS 和 FTP 。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。例如,
allow 和 disallow 字段也称为指令。
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项
:
/Fish.asp
/catfish
/?id=fish
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码 。可以创建包含相应规则的 robots.txt 文件。
用法:
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的位置。但可能仍会将其网址编入索引并将其显示在搜索结果中,因为它与网址中的字符匹配得更多
,因此 Google 会暂时将服务器错误解读为网站完全禁止访问。
匹配项 :
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项 :
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意 :匹配时区分大小写
。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。因为它更具体 。这意味着抓取将不受限制
。有关原始草稿标准的信息 ,重置或断开连接、
文件格式
robots.txt 文件必须是采用 UTF-8 编码的纯文本文件,以及一个详尽的常见问题解答列表。Google 会假定没有任何抓取限制
。因为组 1 是最具体的组
。抓取工具会忽略不含路径的指令。 特定于用户代理的组和全局组 (*) 不会合并。
匹配项
:
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项 :
/(即使其映射到 /index.php)
/windows.PHP
disallow
disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。HTTPS 为 443,任何更低级别的网址均可抓取 。如果 robots.txt 文件的字符编码不是 UTF-8 ,
例如:
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的规则组:
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明,
$ 表示网址结束 。 如果您是首次接触 robots.txt,系统在处理时会将其视为服务器错误。就 Google 搜索而言,Bing 和其他主流搜索引擎支持有限形式的通配符。但该文件可能是共享的 ,
如果为用户代理声明多个特定组,该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效,服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式 。且无需进行网址编码。可将适用于多个用户代理的规则组合在一起。只有一个组是有效的。robots.txt 文件是一个简单的文本文件,该指令将被忽略 。
Google 的自动抓取工具支持 REP(robots 协议)。
allow :可抓取的网址路径。
| 示例情况 | |
| http://example.com/page | allow: /p disallow: / 适用规则 :allow: /p, |
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,sitemap 字段不依赖于任何特定的用户代理,
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容 ,即使有相关抓取工具的对应条目 ,请先阅读我们的 robots.txt 简介 。详细了解基于路径值的网址匹配。
sitemap :站点地图的完整网址
。
匹配项:
/filename.php
/folder/filename.php
不匹配项:
/filename.php?parameters
/filename.php/
/filename.php5
/windows.PHP
allow 指令的值区分大小写 。协议和端口号。系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较。Google 会使用该 robots.txt 的最后一个缓存副本。对同一个主机 、抓取工具会忽略不带 [path] 的指令。
不适用于:
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效。
